Innovation... driven by intelligence and logic

Industrial Training and Project in Linux, C, C++ with QT. Able to

Industrial Training and Project in Linux, C, C++ with QT.

After the training is over, The Trainee should be able to:-

  • Install Linux OS fedora
  • Do User administration (setup and maintaining account), 
  • Maintain systems, Verify ports and peripherals, 
  • Create and mantain file-systems, 
  • Install software and do software management,
  • Build Shell Scripts using Bash from scratch
  • Use structured commands, 
  • Handle user input,
  • Present data, run and control Scripts with Ease
  • Create functions / graphics using scripts
  • Maintainig kernel and filesystems
  • Configuring Remote Login Services: Telnet and SSH
  • RFC 854, ICMP RFC 792, Security, Configuring  TELNET on Linux based systems, Telnet 5250, Telnet data, Related RFCs, Telnet Clients.
  • SSH: Installing Public keys manually and automatically, Using the ssh  agent program, X11 Session Forwarding, TCP Port Forwarding, SOCKS5 proxying, Running Commands Over SSH, Using SCP, using SSH Sessions.
  • Configuring FTP and TFTP Servers
  • FTP: Communication and data transfer, Login Anonymous FTP, NAT and firewall traversal, Differences from HTTP, Web browser support, Security-Secure FTP, FTPS, SFTP, FTP over SSH (not SFTP), FTP reply codes.
  • TFTP: Introduction to protocol, TFTP Clients and Servers, RFC 1350,
  • ​Configuring DHCP Server
  • DHCP discovery, DHCP offer, DHCP request, DHCP acknowledgement, DHCP information, DHCP releasing, Client configuration parameters, DHCP options, Vendor identification, DHCP relaying, Reliability, Security.
  • ​Configuring NFS
  • Versions and variations, NFSv2, NFSv3, NFSv4, Other extensions, Platforms, Typical implementation, Protocol development. Configuring the Server, Configuring the Client, Locking, Automating Mounts.
  • Comfortable with respect to programming in C.
  • Able to Implement and use Data Structures using C.
  • Proficient in Advanced data Structures in C.
  • Having good understanding about gcc compiler.
  • debug complex C programs using gdb.
  • Adept with Project Management tools.
  • Efficient with Source Code Control tools.
  • use the concept absorbed in the real world situation.
  • implement knowledge absorbed in theiir commercial / live projects.
  • The probablity for a head-start to the taiinees career should be higher.
  • Object Oriented Programming Concepts and comfortable with respect to programming in C++.
  • basics of Syntax and Semantics
  • Implement and use Data Structures using C++.
    create Constructors and Destructors
  • implement Memory Management and Pointers
  • Polymorphism: operator overloading, Function Overloading
  • implement Friend Functions
  • use C++ Standard Library: Input/Output with files
  • implement Inheritance: single, public, private and protected, multiple, hierarchical, multilevel, hybrid, multilevel, hybrid
    understand and implement Advanced Concepts:
  • emplates, Namespaces, Exceptions, Preprocessors
  • do Project and Debugging.
  • be Proficient in Abstract Classes and STL Classes.
  • Have good understanding about g++ compiler.
  • debug complex C++ programs using gdb.

Back to Training page...


EmbLogicTM is an ISO 9001:2008(QMS) (Quality Management System) Certified Company

 
Go to Top ^