Innovation... driven by intelligence and logic

Industrial Training and Project in c++ on Linux with QT contents

Modules and Projects in the Training


Serial

No

Module

No

Project Module

Working

Days

Sessions

2 Hrs

Labs

4 Hrs

1 00

Linux Systems Administration ...

5 working days 5 Sessions 5 Labs
After This Module/Project is over, the trainee should be able to understand / implemtnt the following:-
  • Install Linux OS fedora,Ubuntu & Debian
  • Do User administration (setup and maintaining account), 
  • Maintain systems, Verify ports and peripherals, 
  • Quickly arrange repair for h/w in occasion of h/w failure
  • monitor system performance,
  • Create and mantain file-systems, 
  • Install software and do software management,
  • create a backup and recover policy,  
  • monitor Linux n/w communication, configure remote login services,
  • update system as soon as new version of OS and application Software comes out using git,
  • implement the policies for the use of the computer system & network,  
  • Setup security policies, have a strong grasp of computer security (firewalls & intrusion detection systems),
  • understand Process control and Memory control
  • Read More...
2 11

Shell Scripting using Bash ...

10 working days 10 Sessions     5 Labs
After This Module/Project is over, the trainee should be able to understand / implemtnt the following:-
  • Build Shell Scripts using Bash from scratch
  • Use structured commands, 
  • Handle user input,
  • Debug Shell Scripts
  • Understand advanced bash shell commands, Environment variables, and Linux File Permissions
  • Present data, run and control Scripts with Ease
  • Create functions / graphics using scripts
  • Do Scripting using sed, awk, gawk & regular expressions efficiently
  • Configure and use make, makefile
  • Create makefile for system configuration, network configuration, device drivers compilation and insertion
  • Maintainig kernel and filesystems
  • Shell Scripting for creating, maintaning Networks
  • Shell Scripting for embedded linux kernel development
  • Read More...
3 12

Linux Networking & Network Administration...

8 working days 8 Sessions 8 Labs
After This Module/Project is over, the trainee should be able to understand / implemtnt the following:-
  • Configuring Remote Login Services: Telnet and SSH
  • RFC 854, ICMP RFC 792, Security, Configuring  TELNET on Linux based systems, Telnet 5250, Telnet data, Related RFCs, Telnet Clients.
  • SSH: Installing Public keys manually and automatically, Using the ssh  agent program, X11 Session Forwarding, TCP Port Forwarding, SOCKS5 proxying, Running Commands Over SSH, Using SCP, using SSH Sessions.
  • Configuring FTP and TFTP Servers
  • FTP: Communication and data transfer, Login Anonymous FTP, NAT and firewall traversal, Differences from HTTP, Web browser support, Security-Secure FTP, FTPS, SFTP, FTP over SSH (not SFTP), FTP reply codes.
  • TFTP: Introduction to protocol, TFTP Clients and Servers, RFC 1350,
  • ​Configuring DHCP Server
  • DHCP discovery, DHCP offer, DHCP request, DHCP acknowledgement, DHCP information, DHCP releasing, Client configuration parameters, DHCP options, Vendor identification, DHCP relaying, Reliability, Security.
  • ​Configuring NFS
  • Versions and variations, NFSv2, NFSv3, NFSv4, Other extensions, Platforms, Typical implementation, Protocol development. Configuring the Server, Configuring the Client, Locking, Automating Mounts.
  • Read More...
4 01 Data Structures using C ... 35 working days 25 sessions 35 labs
After This Module/Project is over, the trainee should be able to understand / implemtnt the following:-
  • Comfortable with respect to programming in C.
  • Able to Implement and use Data Structures using C.
  • Proficient in Advanced data Structures in C.
  • Having good understanding about gcc compiler.
  • debug complex C programs using gdb.
  • Adept with Project Management tools.
  • Efficient with Source Code Control tools.
  • Read More...
5 02

OOPs using C++ with QT on Linux...

25 working days 20 sessions 25 labs
After This Module/Project is over, the trainee should be able to understand/implemtnt the following:-
  • use the concept absorbed in the real world situation.
  • implement knowledge absorbed in theiir commercial / live projects.
  • The probablity for a head-start to the taiinees career should be higher.
  • Object Oriented Programming Concepts and comfortable with respect to programming in C++.
  • basics of Syntax and Semantics
  • Implement and use Data Structures using C++.
    create Constructors and Destructors
  • implement Memory Management and Pointers
  • Polymorphism: operator overloading, Function Overloading
  • implement Friend Functions
  • use C++ Standard Library: Input/Output with files
  • implement Inheritance: single, public, private and protected, multiple, hierarchical, multilevel, hybrid, multilevel, hybrid
    understand and implement Advanced Concepts:
  • emplates, Namespaces, Exceptions, Preprocessors
  • do Project and Debugging.
  • be Proficient in Abstract Classes and STL Classes.
  • Have good understanding about g++ compiler.
  • debug complex C++ programs using gdb.
  • Read More...
      100 working days 68 Sessions 78 Labs

BACK...


EmbLogic™ is an ISO 9001:2008(QMS) (Quality Management System) Certified Company.

 
Go to Top ^